Marcus OlssonFrilansande webbutvecklare

PSA: 4 månader kvar för PHP 5.6 och PHP 7.0

Utvecklingen av PHP går i rasande takt. Det känns nästan som det vore igår man jobbade i PHP5.2 och det bråkades om kommande PHP6 som till slut gick i graven och hoppades helt över till förmån av 7.0 (viss kod rullades även in i PHP5.6).

Nåväl, kanske inte alla som nördar ner sig särskilt mycket i de olika PHP-versionera, men faktum är att PHP5.6 börjar bli rejält gammalt nu (4-årsdagen är idag!) och alla säkerhetsuppdateringar kommer att avslutas nu i slutet av december.

Redan i början av december stängs även framtida säkerhetspacther för PHP7.0 av.

Att uppdatera gamla/legacy-projekt att köra på nyare system kan vara krångligt – men de allra flesta moderna applikationerna med god kodstandard bör klara av att köra på 7.x utan allt för mycket arbete. Något som man alltså rekommenderas att göra nu då framtida upptäckta säkerhetsluckor inte kommer att åtgärdas.

Webbhotellens PHP-versioner

Det var flera år sedan jag använde ett webbhotell – och vad jag vill minnas så släpade de ofta efter ett par versioner. Men när jag gjorde en snabb kontroll här i morse så erbjöd samtliga kontrollerade (Oderland, Binero och Loopia) PHP7.2 i sitt utbud. Bra!

Läs mer om vilka versioner av PHP som ses som aktiva just nu på php.net.


Kategorier

PHP