Äldre version av PHP? Uppdatera inte till Wordpress 3.4 ännu

Tommy Johannsson (kanske mer känd som TKJ) uppdaterade nyss till den nyaste versionen av Wordpress som släpptes här om dagen, nämligen 3.4 – det gick dock inte som man kan önska. En rad PHP-fel uppstod.

Det verkar ha smugit sig in ett litet fel när det kommer till användandet av PHP-funktionen debug_backtrace() – som har förändrats en del genom de olika versionerna av PHP.

Får du en varning i stil med "wrong parameter count for debug_backtrace()" så beror det på största sannolikhet på att du kör på en för gammal version av PHP. Det går dock enkelt att fixa själv fram tills att Wordpress-utvecklarna gör detta, öppna upp filen functions.php som finns i /wp-includes/ och på rad 3625 ändrar

$trace  = debug_backtrace( false );

till

$trace  = debug_backtrace();

så har du avvärjt felet.

Innan version 5.2.5 av PHP så mottog inte funktionen debug_backtrace() några parametrar, därav varningstexten som uppstår vid uppdateringen av Wordpress.

Om ditt webbhotell förövrigt fortfarande kör på PHP 5.2.5 eller lägre – be dem uppdatera omedelbart – det är en rejält föråldrad version (5.2.4 är ifrån hösten 2007).

Uppdaterad

Då det inte fanns någon existerande rapport av buggen så lade jag upp en via deras buggrapporteringssystem. Får för övrigt hoppas Wordpress snart byter från Trac till ett vettigare system – så som GitHub – för att göra det lite enklare och snabbare, både att rapportera buggar och åtgärda dem.

Uppdaterad 2

Det gick snabbt, en patch är färdig för att ingå i nästa uppdatering, 3.4.1.